diff mbox series

[bug#38423,27/49] gnu: Add ghc-type-hint.

Message ID 20191129113751.82405-27-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-type-hint): New variable.
---
 gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7c1b75a5ed..d5dbff4433 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13749,3 +13749,27 @@  files and directories in a portable way.")
     (description
      "This package provides Internet Protocol data structures")
     (license license:bsd-3)))
+
+(define-public ghc-type-hint
+  (package
+    (name "ghc-type-hint")
+    (version "0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/type-hint/type-hint-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1fcrma7m6y7i1y42rzhv7qch8xkk93lkh1767saw4hsb9fzwsq8i"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/mvv/type-hint")
+    (synopsis
+     "Guide type inference with proxy values")
+    (description
+     "This package provides 'Proxy' values for various types
+from the base library and functions to use these values as
+hints for type inference.")
+    (license license:bsd-3)))