diff mbox series

[bug#38423,28/49] gnu: Add ghc-concise.

Message ID 20191129113751.82405-28-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-concise): New variable.
---
 gnu/packages/haskell-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d5dbff4433..28179eba97 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13773,3 +13773,33 @@  files and directories in a portable way.")
 from the base library and functions to use these values as
 hints for type inference.")
     (license license:bsd-3)))
+
+(define-public ghc-concise
+  (package
+    (name "ghc-concise")
+    (version "0.1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/concise/concise-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "09crgc6gjfidlad6263253xx1di6wfhc9awhira21s0z7rddy9sw"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-lens" ,ghc-lens)))
+    (native-inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-quickcheck-instances"
+        ,ghc-quickcheck-instances)))
+    (home-page
+     "https://github.com/frasertweedale/hs-concise")
+    (synopsis "Utilities for Control.Lens.Cons")
+    (description
+     "concise provides a handful of functions to extend
+what you can do with Control.Lens.Cons.")
+    (license license:bsd-3)))