diff mbox series

[bug#38423,17/49] gnu: Add ghc-bug.

Message ID 20191129113751.82405-17-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-bug): New variable.
---
 gnu/packages/haskell-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c4d2ed3b02..3eadfff08c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13499,3 +13499,25 @@  ExceptT instances in scope.")
     (description
      "'MonadTime' type class for monads which carry the notion of the current time.")
     (license license:bsd-3)))
+
+(define-public ghc-bug
+  (package
+    (name "ghc-bug")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/bug/bug-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1xfynvp5fyn46gg3p5qq9cmb1dnw2dyf3bz6w5wdvikfvs19dwhq"))))
+    (build-system haskell-build-system)
+    (home-page
+     "https://github.com/nikita-volkov/bug")
+    (synopsis
+     "Better alternatives to the \"error\" function")
+    (description "")
+    (license license:expat)))