diff mbox series

[bug#38423,20/49] gnu: Add ghc-data-dword.

Message ID 20191129113751.82405-20-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-data-dword): New variable.
---
 gnu/packages/haskell-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 905beb533b..0b40ec6c6b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13574,3 +13574,33 @@  Haskell for attaching typeclass instances.")
     (description
      "This package provides extra (vs. 'Data.Bits') operations on binary words of fixed length.")
     (license license:bsd-3)))
+
+(define-public ghc-data-dword
+  (package
+    (name "ghc-data-dword")
+    (version "0.3.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/data-dword/data-dword-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "084invjg8zj7ndxnz9clqmq06ch47k1d9lhxwap6xs0x4807crvb"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-hashable" ,ghc-hashable)
+       ("ghc-data-bword" ,ghc-data-bword)))
+    (native-inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (home-page "https://github.com/mvv/data-dword")
+    (synopsis
+     "Stick two binary words together to get a bigger one")
+    (description
+     "This package provides Template Haskell utilities for declaring
+fixed-length binary word data types.  Signed and unsigned
+96, 128, 160, 192, 224, and 256-bit types are predefined.")
+    (license license:bsd-3)))