diff mbox series

[bug#38423,19/49] gnu: Add ghc-data-bword.

Message ID 20191129113751.82405-19-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-data-bword): New variable.
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 497ce4a5e6..905beb533b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13549,3 +13549,28 @@  ExceptT instances in scope.")
      "This package provides a canonical anonymous 1-tuple type missing from
 Haskell for attaching typeclass instances.")
     (license license:bsd-3)))
+
+(define-public ghc-data-bword
+  (package
+    (name "ghc-data-bword")
+    (version "0.1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/data-bword/data-bword-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0zfvk7b7qi6inra0kc03rhsic2rj0818n4i03lfwzvb5g22izw3h"))))
+    (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+    (home-page "https://github.com/mvv/data-bword")
+    (synopsis
+     "Extra operations on binary words of fixed length")
+    (description
+     "This package provides extra (vs. 'Data.Bits') operations on binary words of fixed length.")
+    (license license:bsd-3)))