diff mbox series

[bug#38423,02/49] gnu: Add ghc-text-latin1.

Message ID 20191129113751.82405-2-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-text-latin1): New package.
---
 gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a267685f99..f22c936920 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13179,3 +13179,32 @@  compression ratios.")
      "This package provides an interface for injecting text
 into monoids such as builders and printers.")
     (license license:bsd-3)))
+
+(define-public ghc-text-latin1
+  (package
+    (name "ghc-text-latin1")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/text-latin1/text-latin1-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1wxbv6m567n3330baw2k0xxd50nhn2k6w3lgmpk6zq7x1jp84x3c"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-data-checked" ,ghc-data-checked)
+       ("ghc-semigroups" ,ghc-semigroups)
+       ("ghc-case-insensitive" ,ghc-case-insensitive)
+       ("ghc-hashable" ,ghc-hashable)))
+    (home-page "https://github.com/mvv/text-latin1")
+    (synopsis
+     "Latin-1 (including ASCII) utility functions")
+    (description
+     "This package provides various functions over the
+ASCII and Latin-1 portions of the 'Char' and 'Word8'
+data types.")
+    (license license:bsd-3)))