diff mbox series

[bug#38423,34/49] gnu: Add ghc-heredoc.

Message ID 20191129113751.82405-34-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-heredoc): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 8637f5c637..f876709648 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13983,3 +13983,26 @@  encoders from the postgresql-binary library have shown a stable performance
 improvement by factors of up to 10 after the migration from the standard builder
 to bytestring-strict-builder.")
     (license license:expat)))
+
+(define-public ghc-heredoc
+  (package
+    (name "ghc-heredoc")
+    (version "0.2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/heredoc/heredoc-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0h0g2f7yscwl1ba1yn3jnz2drvd6ns9m910hwlmq3kdq3k39y3f9"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/heredoc")
+    (synopsis
+     "multi-line string / here document using QuasiQuotes")
+    (description
+     "multi-line string / here document using QuasiQuotes")
+    (license license:public-domain)))