diff mbox series

[bug#38423,36/49] gnu: Add ghc-loch-th.

Message ID 20191129113751.82405-36-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-loch-th): New variable.
---
 gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d401ddd469..1b9db3f519 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14031,3 +14031,27 @@  to bytestring-strict-builder.")
     (description
      "QuasiQuoter for Perl6-style multi-line interpolated strings.")
     (license license:public-domain)))
+
+(define-public ghc-loch-th
+  (package
+    (name "ghc-loch-th")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/loch-th/loch-th-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1hvdkcyrlnv65q8x8h0441x30wr9bbfbg3961xd3fy9an5r961fc"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/liskin/loch-th")
+    (synopsis
+     "Support for precise error locations in source files (Template Haskell version)")
+    (description
+     "This module provides a Template Haskell based mechanism to tag failures with
+the location of the failure call.  The location message includes the file name,
+line and column numbers.")
+    (license license:bsd-3)))