diff mbox series

[bug#38423,16/49] gnu: Add ghc-monad-time.

Message ID 20191129113751.82405-16-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-monad-time): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index be5b7b64d5..c4d2ed3b02 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13476,3 +13476,26 @@  all of ExceptT's monad class instances. Therefore, you may have to declare
 import Control.Monad.Except () at the top of your file to get all of the
 ExceptT instances in scope.")
     (license license:bsd-3)))
+
+(define-public ghc-monad-time
+  (package
+    (name "ghc-monad-time")
+    (version "0.3.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/monad-time/monad-time-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0z30c0k5bqlz86vwajnm6kj26i09zx6dzqwd00z6ba8hqyzm1x0a"))))
+    (build-system haskell-build-system)
+    (home-page
+     "https://github.com/scrive/monad-time")
+    (synopsis
+     "Type class for monads which carry the notion of the current time.")
+    (description
+     "'MonadTime' type class for monads which carry the notion of the current time.")
+    (license license:bsd-3)))