diff mbox series

[bug#38423,41/49] gnu: Add ghc-hasql-pool.

Message ID 20191129113751.82405-41-rob@vllmrt.net
State Accepted
Headers show
Series [bug#38423,01/49] gnu: Add ghc-text-printer. | expand

Commit Message

Robert Vollmert Nov. 29, 2019, 11:37 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-hasql-pool): New variable.
---
 gnu/packages/haskell-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 6f24921b5f..79091ddae4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -14203,3 +14203,31 @@  with the integer_datetimes setting off and on.")
 The API is completely disinfected from exceptions.
 All error-reporting is explicit and is presented using the Either type.")
     (license license:expat)))
+
+(define-public ghc-hasql-pool
+  (package
+    (name "ghc-hasql-pool")
+    (version "0.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/hasql-pool/hasql-pool-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0agl5ilp0amsp9pidhmgivdyaq43x3xi7hb80c91n9l92pv6163k"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-resource-pool" ,ghc-resource-pool)
+       ("ghc-hasql" ,ghc-hasql)
+       ("ghc-base-prelude" ,ghc-base-prelude)))
+    (arguments
+     `(#:tests?  ; tests require a running postgres
+       #f))
+    (home-page
+     "https://github.com/nikita-volkov/hasql-pool")
+    (synopsis "A pool of connections for Hasql")
+    (description "A pool of connections for Hasql")
+    (license license:expat)))