diff mbox series

[bug#54560,09/47] gnu: Add go-github-com-go-kit-log.

Message ID 20220325133211.5128-9-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-kit-log): New variable.
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 943f32edcf..e2bf81528f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9865,6 +9865,32 @@  (define-public go-github-com-edsrzf-mmap-go
     (home-page "https://github.com/edsrzf/mmap-go")
     (license license:bsd-3)))
 
+(define-public go-github-com-go-kit-log
+  (package
+    (name "go-github-com-go-kit-log")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-kit/log")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "13gbqrwvqy9j903j44x0kix5gnn34a8hl8skbdijy7arpkxpj6h3"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/go-kit/log"))
+    (propagated-inputs (list go-github-com-go-logfmt-logfmt))
+    (synopsis "Minimal and extensible structured logger")
+    (description
+     "@code{package log} provides a minimal interface for structured
+logging in services.  It may be wrapped to encode conventions, enforce
+type-safety, provide leveled logging, and so on.  It can be used for
+both typical application log events, and log-structured data streams.")
+    (home-page "https://github.com/go-kit/log")
+    (license license:expat)))
+
 (define-public go-github-com-go-logfmt-logfmt
   (package
     (name "go-github-com-go-logfmt-logfmt")