diff mbox series

[bug#54560,44/47] gnu: Add go-github-com-go-openapi-validate.

Message ID 20220325133211.5128-44-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:32 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-openapi-validate): New
variable.
---
 gnu/packages/golang.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7d679e825f..e4a09fea4a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10351,6 +10351,36 @@  (define-public go-github-com-go-openapi-swag
     (home-page "https://github.com/go-openapi/swag")
     (license license:asl2.0)))
 
+(define-public go-github-com-go-openapi-validate
+  (package
+    (name "go-github-com-go-openapi-validate")
+    (version "0.21.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-openapi/validate")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ga0jcb8hzfcx2rhysz1cxixs9hib1rv3qhvhn6ssb9xlx2p4fnq"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/go-openapi/validate"))
+    (propagated-inputs (list go-github-com-go-openapi-analysis
+                             go-github-com-go-openapi-errors
+                             go-github-com-go-openapi-jsonpointer
+                             go-github-com-go-openapi-loads
+                             go-github-com-go-openapi-spec
+                             go-github-com-go-openapi-strfmt
+                             go-github-com-go-openapi-swag))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (synopsis "OpenAPI toolkit validation helpers")
+    (description "This package provides helpers to validate Swagger 2.0
+specification (aka OpenAPI 2.0).")
+    (home-page "https://github.com/go-openapi/validate")
+    (license license:asl2.0)))
+
 (define-public go-github-com-go-stack-stack
   (package
     (name "go-github-com-go-stack-stack")