diff mbox series

[bug#54560,19/47] gnu: Add go-github-com-oklog-ulid.

Message ID 20220325133211.5128-19-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-oklog-ulid): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ebd2ac95b2..c84f3b499c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10153,6 +10153,31 @@  (define-public go-github-com-oklog-run
     (home-page "https://github.com/oklog/run")
     (license license:asl2.0)))
 
+(define-public go-github-com-oklog-ulid
+  (package
+    (name "go-github-com-oklog-ulid")
+    (version "1.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/oklog/ulid")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0hybwyid820n80axrk863k2py93hbqlq6hxhf84ppmz0qd0ys0gq"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/oklog/ulid"))
+    (synopsis "Universally Unique Lexicographically Sortable Identifier
+(ULID) in Go")
+    (description
+     "Universally Unique Lexicographically Sortable Identifier (ULID) in
+Go.  A Go port of @code{ulid/javascript} with binary format
+implemented.")
+    (home-page "https://github.com/oklog/ulid")
+    (license license:asl2.0)))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")