diff mbox series

[bug#54560,28/47] gnu: Add go-github-com-tidwall-pretty.

Message ID 20220325133211.5128-28-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-tidwall-pretty): New variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 58a66e95b7..e39d0ec062 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10415,6 +10415,30 @@  (define-public go-github-com-simonpasquier-klog-gokit-v3
     (arguments
      '(#:import-path "github.com/simonpasquier/klog-gokit/v3"))))
 
+(define-public go-github-com-tidwall-pretty
+  (package
+    (name "go-github-com-tidwall-pretty")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tidwall/pretty")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "11zi5hxb75yapgxq67r4lmv8n910iqmw7994ig1fy4gnr4d51i3s"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/tidwall/pretty"))
+    (synopsis "Efficient JSON beautifier and compactor for Go")
+    (description
+     "Pretty is a Go package that provides fast methods for
+formatting JSON for human readability, or to compact JSON for smaller
+payloads.")
+    (home-page "https://github.com/tidwall/pretty")
+    (license license:expat)))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")