diff mbox series

[bug#54560,06/47] gnu: Add go-github-com-dennwc-varint.

Message ID 20220325133211.5128-6-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-dennwc-varint): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

M March 25, 2022, 7:30 p.m. UTC | #1
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
> +      (synopsis "Fast varint library for Go")

From (guix)Synopses and Descriptions:

   Keep in mind that the synopsis must be meaningful for a very wide
audience.  For example, “Manipulate alignments in the SAM format” might
make sense for a seasoned bioinformatics researcher, but might be
fairly unhelpful or even misleading to a non-specialized audience.  It
is a good idea to come up with a synopsis that gives an idea of the
application domain of the package.  In this example, this might give
something like “Manipulate nucleotide sequence alignments”, which
hopefully gives the user a better idea of whether this is what they are
looking for.

I guess it is an implementation of bignums and bignum arithmetic? 
Maybe "Arithmetic on arbitrarily large numbers"?

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ee22952fe7..078cb30cbc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9817,6 +9817,31 @@  (define-public go-github-com-asaskevich-govalidator
     (home-page "https://github.com/asaskevich/govalidator")
     (license license:expat)))
 
+(define-public go-github-com-dennwc-varint
+  ;; Test fixes haven't received a tag yet.
+  (let ((commit "2d9bdf4e8e69d9b1d5cbc270960451dda46c3231")
+        (revision "0"))
+    (package
+      (name "go-github-com-dennwc-varint")
+      (version (git-version "1.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/dennwc/varint")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0050g9z6s40j8h5m7sw121i0wb0yp6yipsp5xlqlx2hrwa7ha8l3"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/dennwc/varint"))
+      (synopsis "Fast varint library for Go")
+      (description "This package provides an optimized implementation of
+protobuf's varint encoding/decoding.")
+      (home-page "https://github.com/dennwc/varint")
+      (license license:expat))))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")