diff mbox series

[bug#54560,02/47] gnu: go-github-com-golang-protobuf-proto: Update to 1.5.2.

Message ID 20220325133211.5128-2-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-golang-protobuf-proto): Update
to 1.5.2.
[arguments]: Enable tests.
---
 gnu/packages/golang.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

Comments

M March 25, 2022, 7:12 p.m. UTC | #1
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
> -       ;; Requires unpackaged golang.org/x/sync/errgroup
> -       #:tests? #f))
> +       #:unpack-path "github.com/golang/protobuf"))
> +    (propagated-inputs (list go-google-golang-org-protobuf))
> +    (native-inputs (list go-github-com-google-go-cmp-cmp))

I'm not seeing go-golang.org-x-sync-errgroup here.  So my question is:
does this package build?
Leo Nikkilä March 25, 2022, 10:55 p.m. UTC | #2
> I'm not seeing go-golang.org-x-sync-errgroup here.

The errgroup dependency was dropped in 1.3.1:
<https://github.com/golang/protobuf/commit/9bfdceed46565e0aca8cf0fb9cbb9fd37131fbd2>

Later in 1.4.0, the package was rewritten in terms of google.golang.org/protobuf, thus the added dependency:
<https://github.com/golang/protobuf/releases/tag/v1.4.0>
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 455c4daf30..6945680e0e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6504,7 +6504,7 @@  (define-public gotestsum
 (define-public go-github-com-golang-protobuf-proto
   (package
     (name "go-github-com-golang-protobuf-proto")
-    (version "1.3.1")
+    (version "1.5.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -6513,13 +6513,13 @@  (define-public go-github-com-golang-protobuf-proto
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "15am4s4646qy6iv0g3kkqq52rzykqjhm4bf08dk0fy2r58knpsyl"))))
+                "1mh5fyim42dn821nsd3afnmgscrzzhn3h8rag635d2jnr23r1zhk"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/golang/protobuf/proto"
-       #:unpack-path "github.com/golang/protobuf"
-       ;; Requires unpackaged golang.org/x/sync/errgroup
-       #:tests? #f))
+       #:unpack-path "github.com/golang/protobuf"))
+    (propagated-inputs (list go-google-golang-org-protobuf))
+    (native-inputs (list go-github-com-google-go-cmp-cmp))
     (synopsis "Go support for Protocol Buffers")
     (description "This package provides Go support for the Protocol Buffers
 data serialization format.")