diff mbox series

[bug#54560,03/47] gnu: Add go-github-com-golang-protobuf-ptypes.

Message ID 20220325133211.5128-3-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-golang-protobuf-ptypes): New
variable.
---
 gnu/packages/golang.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

M March 25, 2022, 7:14 p.m. UTC | #1
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
> +(define-public go-github-com-golang-protobuf-ptypes
> +  (package
> +    (inherit go-github-com-golang-protobuf-proto)
> +    (name "go-github-com-golang-protobuf-ptypes")
> +    (arguments
> +     '(#:import-path "github.com/golang/protobuf/ptypes"
> +       #:unpack-path "github.com/golang/protobuf"))))

go-google-golang-org-protobuf (which presumably contains the ptypes
stuff) has been packaged in 01/47, so is this separate package
still necessary?
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6945680e0e..f8ca9cf580 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6526,6 +6526,14 @@  (define-public go-github-com-golang-protobuf-proto
     (home-page "https://github.com/golang/protobuf")
     (license license:bsd-3)))
 
+(define-public go-github-com-golang-protobuf-ptypes
+  (package
+    (inherit go-github-com-golang-protobuf-proto)
+    (name "go-github-com-golang-protobuf-ptypes")
+    (arguments
+     '(#:import-path "github.com/golang/protobuf/ptypes"
+       #:unpack-path "github.com/golang/protobuf"))))
+
 (define-public go-github-com-mattn-go-zglob
   (package
     (name "go-github-com-mattn-go-zglob")