diff mbox series

[bug#54560,08/47] gnu: Add go-github-com-go-logfmt-logfmt.

Message ID 20220325133211.5128-8-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-go-logfmt-logfmt): New
variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

M March 25, 2022, 7:38 p.m. UTC | #1
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
> +    (synopsis "Marshals and unmarshals logfmt messages")

I think the less fancy words ‘encode’ and ‘decode’ are more widely
understood and just as accurate.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4f55acf1ad..943f32edcf 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9865,6 +9865,30 @@  (define-public go-github-com-edsrzf-mmap-go
     (home-page "https://github.com/edsrzf/mmap-go")
     (license license:bsd-3)))
 
+(define-public go-github-com-go-logfmt-logfmt
+  (package
+    (name "go-github-com-go-logfmt-logfmt")
+    (version "0.5.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/go-logfmt/logfmt")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "01fs4x2aqw2qcsz18s4nfvyqv3rcwz5xmgpk3bic6nzgyzsjd7dp"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/go-logfmt/logfmt"))
+    (synopsis "Marshals and unmarshals logfmt messages")
+    (description
+     "@code{package logfmt} implements utilities to marshal and
+unmarshal data in the logfmt format.  It provides an API similar to
+@code{encoding/json} and @code{encoding/xml}.")
+    (home-page "https://github.com/go-logfmt/logfmt")
+    (license license:expat)))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")