diff mbox series

[bug#54560,14/47] gnu: Add go-github-com-modern-go-concurrent.

Message ID 20220325133211.5128-14-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-modern-go-concurrent): New
variable.
---
 gnu/packages/golang.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

M March 25, 2022, 7:50 p.m. UTC | #1
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
>  including a backported version of
> +@code{sync.Map} for Go < 1.9

The Go in Guix is >1.9.
M March 25, 2022, 7:51 p.m. UTC | #2
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
> +     "Concurrency utilities for Go, including a backported version of
> +@code{sync.Map} for Go < 1.9 named @code{concurrent.Map}, and
> +@code{concurrent.Executor}.")

It would be nice to actually describe what this package provides
instead of mentioning some symbols.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 15a2f4310b..61332a5786 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10027,6 +10027,30 @@  (define-public go-github-com-mailru-easyjson
     (home-page "https://github.com/mailru/easyjson")
     (license license:expat)))
 
+(define-public go-github-com-modern-go-concurrent
+  (package
+    (name "go-github-com-modern-go-concurrent")
+    (version "1.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/modern-go/concurrent")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0s0fxccsyb8icjmiym5k7prcqx36hvgdwl588y0491gi18k5i4zs"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/modern-go/concurrent"))
+    (synopsis "Concurrency utilities for Go")
+    (description
+     "Concurrency utilities for Go, including a backported version of
+@code{sync.Map} for Go < 1.9 named @code{concurrent.Map}, and
+@code{concurrent.Executor}.")
+    (home-page "https://github.com/modern-go/concurrent")
+    (license license:asl2.0)))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")