diff mbox series

[bug#54560,17/47] gnu: Add go-github-com-mwitkow-go-conntrack.

Message ID 20220325133211.5128-17-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-mwitkow-go-conntrack): New
variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e55c5de616..e60d29b75e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10100,6 +10100,34 @@  (define-public go-github-com-montanaflynn-stats
     (home-page "https://github.com/montanaflynn/stats")
     (license license:expat)))
 
+(define-public go-github-com-mwitkow-go-conntrack
+  (let ((commit "2f068394615f73e460c2f3d2c158b0ad9321cadb")
+        (revision "0"))
+    (package
+      (name "go-github-com-mwitkow-go-conntrack")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/mwitkow/go-conntrack")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0ymjmy12ks7smgwmrwsa5kf07d9w5kpk1dn650azlzr61b561aw7"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/mwitkow/go-conntrack"))
+      (propagated-inputs (list go-github-com-jpillora-backoff
+                               go-github-com-prometheus-client-golang
+                               go-golang-org-x-net))
+      (native-inputs (list go-github-com-stretchr-testify))
+      (synopsis "Go middleware for @code{net.Conn} tracing")
+      (description "Prometheus monitoring and @code{x/net/trace} tracing
+wrappers for @code{net.Conn}.")
+      (home-page "https://github.com/mwitkow/go-conntrack")
+      (license license:asl2.0))))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")