diff mbox series

[bug#54560,31/47] gnu: Add go-github-com-youmark-pkcs8.

Message ID 20220325133211.5128-31-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-youmark-pkcs8): New variable.
---
 gnu/packages/golang.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4f1de715d0..d16326e52c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10495,6 +10495,34 @@  (define-public go-github-com-uber-jaeger-lib
     (home-page "https://github.com/jaegertracing/jaeger-lib")
     (license license:asl2.0)))
 
+(define-public go-github-com-youmark-pkcs8
+  (package
+    (name "go-github-com-youmark-pkcs8")
+    (version "1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/youmark/pkcs8")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0g20ydzhxrcrnm4azvgd1013cns7qiwsz1469w9mr2rwy4h2g8qn"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/youmark/pkcs8"))
+    (propagated-inputs (list go-golang-org-x-crypto))
+    (synopsis "Functions to parse and convert private keys in PKCS#8
+format")
+    (description
+     "@code{pkcs8} implements functions to process private keys in
+PKCS#8 format, as defined in RFC 5208 and RFC 5958.
+
+It can handle both unencrypted PKCS#8 PrivateKeyInfo format and
+EncryptedPrivateKeyInfo format with PKCS#5 (v2.0) algorithms.")
+    (home-page "https://github.com/youmark/pkcs8")
+    (license license:expat)))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")