diff mbox series

[bug#54560,07/47] gnu: Add go-github-com-edsrzf-mmap-go.

Message ID 20220325133211.5128-7-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-edsrzf-mmap-go): New variable.
---
 gnu/packages/golang.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

M March 25, 2022, 7:33 p.m. UTC | #1
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
> +    (synopsis "Portable mmap package for Go")
> +    (description "@code{mmap-go} is a portable mmap package for the Go

To me, the note about portability doesn't seem very relevant to people
using Guix, though I suppose there is an argument to be made for
developers looking for sufficiently portable libraries.  Guix only
supports GNU targets (GNU/Linux and GNU/Hurd), and I doubt that mmap-go
supports DOS. Everything is unportable, it's the degree of portability
that matters, and the description doesn't qualify the statement ...

Greetings,
Maxime.
M March 25, 2022, 7:35 p.m. UTC | #2
Leo Nikkilä schreef op vr 25-03-2022 om 15:31 [+0200]:
> +    (synopsis "Portable mmap package for Go")

'mmap' is a C-ism, maybe "Map files into virtual memory", with a
mention of 'mmap' in the description?
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 078cb30cbc..4f55acf1ad 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9842,6 +9842,29 @@  (define-public go-github-com-dennwc-varint
       (home-page "https://github.com/dennwc/varint")
       (license license:expat))))
 
+(define-public go-github-com-edsrzf-mmap-go
+  (package
+    (name "go-github-com-edsrzf-mmap-go")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/edsrzf/mmap-go")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "11xpfcacfvmrkbp0pv4j8pg2gyjnxpfp7l93j42h0svwxywhjmrc"))))
+    (build-system go-build-system)
+    (propagated-inputs (list go-golang-org-x-sys))
+    (arguments
+     '(#:import-path "github.com/edsrzf/mmap-go"))
+    (synopsis "Portable mmap package for Go")
+    (description "@code{mmap-go} is a portable mmap package for the Go
+programming language.")
+    (home-page "https://github.com/edsrzf/mmap-go")
+    (license license:bsd-3)))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")