diff mbox series

[bug#54560,18/47] gnu: Add go-github-com-oklog-run.

Message ID 20220325133211.5128-18-hello@lnikki.la
State New
Headers show
Series [bug#54560,01/47] gnu: Add go-google-golang-org-protobuf. | expand

Commit Message

Leo Nikkilä March 25, 2022, 1:31 p.m. UTC
* gnu/packages/golang.scm (go-github-com-oklog-run): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e60d29b75e..ebd2ac95b2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10128,6 +10128,31 @@  (define-public go-github-com-mwitkow-go-conntrack
       (home-page "https://github.com/mwitkow/go-conntrack")
       (license license:asl2.0))))
 
+(define-public go-github-com-oklog-run
+  (package
+    (name "go-github-com-oklog-run")
+    (version "1.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/oklog/run")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0r55p3kgdkgw55i33lqvvvl60mjp92mhd1170m980sw98z9150jk"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/oklog/run"))
+    (synopsis "Universal mechanism to manage goroutine lifecycles")
+    (description
+     "@code{run.Group} is a universal mechanism to manage goroutine
+lifecycles, written to manage component lifecycles in @code{func main}
+for OK Log.  It's useful in any circumstance where you need to
+orchestrate multiple goroutines as a unit whole.")
+    (home-page "https://github.com/oklog/run")
+    (license license:asl2.0)))
+
 (define-public go-google-golang-org-protobuf
   (package
     (name "go-google-golang-org-protobuf")