diff mbox series

[bug#63894,44/55] gnu: Add perl-gravatar-url.

Message ID 20230604174249.30044-44-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl-web.scm (perl-gravatar-url): New variable.
---
 gnu/packages/perl-web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index c3a3e17188..28cc0e6308 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -125,3 +125,29 @@  (define-public perl-uri-nested
      "@code{URI::Nested} provides support for nested URIs, where the scheme is
 a prefix, and the remainder of the URI is another URI.")
     (license license:perl-license)))
+
+(define-public perl-gravatar-url
+  (package
+    (name "perl-gravatar-url")
+    (version "1.07")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/M/MS/MSCHWERN/Gravatar-URL-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1mxnd70xsb7kxd1sf8s7phcds2nf0m8b8asmy3ikv76wzfpbvji3"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build
+                         perl-test-mockrandom
+                         perl-test-warn))
+    (propagated-inputs (list perl-net-dns perl-uri))
+    (home-page "https://metacpan.org/release/Gravatar-URL")
+    (synopsis "Make URLs for Gravatars from an email address")
+    (description
+     "This module looks up the Gravatar for any email address by constructing
+a URL to get the image from @url{gravatar.com}.  A Gravatar is a Globally
+Recognized Avatar for a given email address. This allows you to have a global
+picture associated with your email address.")
+    (license license:perl-license)))