diff mbox series

[bug#63894,40/55] gnu: Add perl-tie-hash-method.

Message ID 20230604174249.30044-40-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-tie-hash-method): New variable.
---
 gnu/packages/perl.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3e1cc4781c..ade4c00264 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11715,6 +11715,28 @@  (define-public perl-tie-handle-offset
 by modifying the @code{seek()} and @code{tell()} calls.")
     (license license:asl2.0)))
 
+(define-public perl-tie-hash-method
+  (package
+    (name "perl-tie-hash-method")
+    (version "0.02")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/Y/YV/YVES/Tie-Hash-Method-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1a9jxhg1jl5rcxnhcmgadl3wcznzjihwxgd1chgcmxqk2jszn4ym"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Tie-Hash-Method")
+    (synopsis "Tied hash with specific methods overriden by callbacks")
+    (description
+     "@code{Tie::Hash::Method} provides a way to create a tied hash with
+specific overriden behaviour without having to create a new class to do it.  A
+tied hash with no methods overriden is functionally equivalent to a normal
+hash.")
+    (license (package-license perl))))
+
 (define-public perl-tie-simple
   (package
     (name "perl-tie-simple")