diff mbox series

[bug#63894,36/55] gnu: Add perl-text-iconv.

Message ID 20230604174249.30044-36-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-text-iconv): New variable.
---
 gnu/packages/perl.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 324832d2c1..503bd167c8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11293,6 +11293,29 @@  (define-public perl-text-haml
 @url{http://haml.info/docs/yardoc/file.REFERENCE.html} specification.")
     (license license:artistic2.0)))
 
+(define-public perl-text-iconv
+  (package
+    (name "perl-text-iconv")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/M/MP/MPIOTR/Text-Iconv-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "1hymsbkjkl43wg74p7hgpyjl8yx1chc9g25spj9l7lq9wzavg02v"))))
+    (build-system perl-build-system)
+    (inputs (list libiconv))
+    (home-page "https://metacpan.org/release/Text-Iconv")
+    (synopsis "Perl interface to iconv() codeset conversion function")
+    (description
+     "This module provides a Perl interface to the @code{iconv()} codeset
+conversion function, as defined by the Single UNIX Specification.  For
+more details see the POD documentation embedded in the file @file{Iconv.pm},
+which will also be installed as @code{Text::Iconv(3)} man page.")
+    (license license:perl-license)))
+
 (define-public perl-text-neattemplate
   (package
     (name "perl-text-neattemplate")