diff mbox series

[bug#63894,38/55] gnu: Add perl-text-reform.

Message ID 20230604174249.30044-38-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-text-reform): New variable.
---
 gnu/packages/perl.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ce6a506fb2..25887f3a71 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11417,6 +11417,31 @@  (define-public perl-text-recordparser
 delimited.")
     (license license:gpl2)))
 
+(define-public perl-text-reform
+  (package
+    (name "perl-text-reform")
+    (version "1.20")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/C/CH/CHORNY/Text-Reform-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "0qdfnhfn8frnkbpkkw64fhnnxsbb6mmb6dr30c0p1jdaq7c2syd8"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build))
+    (home-page "https://metacpan.org/release/Text-Reform")
+    (synopsis "Manual text wrapping and reformatting")
+    (description
+     "The @code{form()} subroutine may be exported from the module.  It takes
+a series of format (or \"picture\") strings followed by replacement values,
+interpolates those values into each picture string, and returns the result.
+The effect is similar to the inbuilt perl format mechanism, although the
+field specification syntax is simpler and some of the formatting behaviour is
+more sophisticated.")
+    (license license:perl-license)))
+
 (define-public perl-text-roman
   (package
     (name "perl-text-roman")