diff mbox series

[bug#63894,30/55] gnu: Add perl-package-variant.

Message ID 20230604174249.30044-30-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-package-variant): New variable.
---
 gnu/packages/perl.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index afcc708458..714f31ccea 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8899,6 +8899,36 @@  (define-public perl-package-stash-xs
 compiler.")
     (license (package-license perl))))
 
+(define-public perl-package-variant
+  (package
+    (name "perl-package-variant")
+    (version "1.003002")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/M/MS/MSTROUT/Package-Variant-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1p1n2ny5fb15bcbykyn523w6sv968gqs7nhjfm36dpac5yfq9vdj"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-moo perl-test-fatal perl-test-most))
+    (propagated-inputs (list perl-carp
+                             perl-import-into
+                             perl-module-runtime
+                             perl-strictures-2))
+    (home-page "https://metacpan.org/release/Package-Variant")
+    (synopsis "Parameterizable packages")
+    (description
+     "This module allows you to build a variable package that contains a
+package template and can use it to build variant packages at runtime.  Your
+variable package will export a subroutine which will build a variant package,
+combining its arguments with the template, and return the name of the new
+variant package.  The implementation does not care about what kind of packages
+it builds, be they simple function exporters, classes, singletons or something
+else.")
+    (license license:perl-license)))
+
 (define-public perl-padwalker
   (package
     (name "perl-padwalker")