diff mbox series

[bug#63894,34/55] gnu: perl-text-balanced: Update to 1.75.

Message ID 20230604174249.30044-34-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-text-balanced): Update to 1.75.
---
 gnu/packages/perl.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4131164022..4ac46172db 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11075,6 +11075,32 @@  (define-public perl-text-aligner
 used to justify strings to various alignment styles.")
     (license license:x11)))
 
+(define-public perl-text-autoformat
+  (package
+    (name "perl-text-autoformat")
+    (version "1.75")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/N/NE/NEILB/Text-Autoformat-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0wdpqq1cds68i1clx2y22bnnm558d12sr7dmypdv9i5f7p7g9m4x"))))
+    (build-system perl-build-system)
+    (propagated-inputs (list perl-text-reform))
+    (home-page "https://metacpan.org/release/Text-Autoformat")
+    (synopsis "Automatic text wrapping and reformatting")
+    (description
+     "The fundamental task of the autoformat subroutine is to identify and
+rearrange independent paragraphs in a text.  Paragraphs typically consist of a
+series of lines containing at least one non-whitespace character, followed by
+one or more lines containing only optional whitespace.  This is a more liberal
+definition than many other formatters use: most require an empty line to
+terminate a paragraph.  Paragraphs may also be denoted by bulleting, numbering,
+or quoting (see the following sections).")
+    (license license:perl-license)))
+
 (define-public perl-text-balanced
   (package
     (name "perl-text-balanced")