diff mbox series

[bug#63894,11/55] gnu: Add perl-test-fork.

Message ID 20230604174249.30044-11-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl-check.scm (perl-test-fork): New variable.
---
 gnu/packages/perl-check.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 530dba3708..156562eaa3 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -735,6 +735,29 @@  (define-public perl-test-files
 contents of a file is equal to a particular string.")
     (license perl-license)))
 
+(define-public perl-test-fork
+  (package
+    (name "perl-test-fork")
+    (version "0.02")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/M/MS/MSCHWERN/Test-Fork-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "0gnh8m81fdrwmzy1fix12grfq7sf7nn0gbf24zlap1gq4kxzpzpw"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build))
+    (home-page "https://metacpan.org/release/Test-Fork")
+    (synopsis "Test code which forks")
+    (description
+     "Testing code which forks is problematic because each test has a number
+associated with it.  Coordinating the test number amongst the parent and child
+processes is complicated. @code{Test::Fork} provides a function to smooth over
+the complications.")
+    (license perl-license)))
+
 (define-public perl-test-harness
   (package
     (name "perl-test-harness")