diff mbox series

[bug#63894,54/55] gnu: Add perl-razor2-client-agent.

Message ID 20230604174249.30044-54-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl-web.scm (perl-razor2-client-agent): New variable.
---
 gnu/packages/perl-web.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index 1054b04fe6..e558b556c9 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -416,3 +416,32 @@  (define-public perl-net-libidn
 much inspired by Turbo Fredriksson's PHP-IDN.")
     (license (list license:gpl1+ license:clarified-artistic))))
 
+(define-public perl-razor2-client-agent
+  ;; TODO: Package razor-agents and razor-agents-sdk
+  (package
+    (name "perl-razor2-client-agent")
+    (version "2.86")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/T/TO/TODDR/Razor2-Client-Agent-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0pw4jhxhm2naqkz0h3gjgdjnygf4019zmvp712vj8pmnxc12w1jy"))))
+    (build-system perl-build-system)
+    (propagated-inputs (list perl-digest-sha1 perl-uri))
+    (home-page "https://metacpan.org/release/Razor2-Client-Agent")
+    (synopsis "Collaborative, content-based spam filtering network agent.")
+    (description
+     "This package provides a client library for Vipul's Razor.  Vipul's Razor
+is a distributed, collaborative, spam detection and filtering network.
+Through user contribution, Razor establishes a distributed and constantly
+updating catalogue of spam in propagation that is consulted by email clients
+to filter out known spam.  Detection is done with statistical and randomized
+signatures that efficiently spot mutating spam content.  User input is
+validated through reputation assignments based on consensus on report and
+revoke assertions which in turn is used for computing confidence values
+associated with individual signatures.")
+    (license license:perl-license)))
+