diff mbox series

[bug#63894,47/55] gnu: Add geolite-country-data.

Message ID 20230604174249.30044-47-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl-web.scm (geolite-country-data): New variable.
---
 gnu/packages/perl-web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index 2b8ba9e219..0bb0070cb5 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -25,6 +25,7 @@  (define-module (gnu packages perl-web)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (guix download)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system perl)
   #:use-module (gnu packages web))
 
@@ -213,3 +214,30 @@  (define-public perl-soap-lite
 @acronym{SOAP, Simple Object Access Protocol}, both on client and server
 side.")
     (license license:perl-license)))
+
+(define-public geolite-country-data
+  ;; TODO: Figure out how to get an updated, free database.
+  (hidden-package
+   (package
+     (name "geolite-country-data")
+     (version "2019-12-06")
+     (source (origin
+               (method url-fetch)
+               (uri (string-append
+                     "https://web.archive.org/web/20181229152721/"
+                     "http://geolite.maxmind.com/download/geoip/database/"
+                     "GeoLiteCountry/" "GeoIP.dat.gz"))
+               (sha256
+                (base32
+                 "0j84ms2x893cpn7x8gffy082gnx882pmr0f6zpfsd46gpyw5xh5r"))))
+     (build-system copy-build-system)
+     (arguments
+      (list #:install-plan #~'(("GeoIP.dat" "share/GeoIP/"))))
+     (home-page "https://dev.maxmind.com/geoip/geolite2-free-geolocation-data")
+     (synopsis "Country-level GeoIP data (December 2018)")
+     (description
+      "This package provides an old GeoIP database in the legacy @file{.dat}
+format.  The data was collected before MaxMind changed the license and format
+of their databases.  It is intended only as a compatability package for
+SpamAssassin.")
+     (license license:cc-by-sa4.0))))