diff mbox series

[bug#63894,19/55] gnu: Add perl-datetime-format-sqlite.

Message ID 20230604174249.30044-19-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-datetime-format-sqlite): New variable.
---
 gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d29c338955..990f107537 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3637,6 +3637,30 @@  (define-public perl-datetime-format-strptime
 takes a string and a pattern and returns the `DateTime` object associated.")
     (license license:artistic2.0)))
 
+(define-public perl-datetime-format-sqlite
+  (package
+    (name "perl-datetime-format-sqlite")
+    (version "0.11")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/C/CF/CFAERBER/DateTime-Format-SQLite-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1d4ln8x5bjpqmgnbbi2h16knfz674dsgvk6x7m60v6ykw454w7yc"))))
+    (build-system perl-build-system)
+    (propagated-inputs (list perl-datetime
+                             perl-datetime-format-builder))
+    (home-page "https://metacpan.org/release/DateTime-Format-SQLite")
+    (synopsis "Parse and format SQLite dates and times")
+    (description
+     "This module understands the formats used by SQLite for its date,
+datetime and time functions.  It can be used to parse these formats in order
+to create DateTime objects, and it can take a DateTime object and produce a
+timestring accepted by SQLite.")
+    (license license:perl-license)))
+
 (define-public perl-datetime-locale
   (package
     (name "perl-datetime-locale")