diff mbox series

[bug#63894,29/55] gnu: Add perl-mldbm.

Message ID 20230604174249.30044-29-antero@mailbox.org
State New
Headers show
Series [bug#63894,01/55] gnu: perl-dbix-class: Update to 0.082843. | expand

Commit Message

Antero Mejr June 4, 2023, 5:42 p.m. UTC
* gnu/packages/perl.scm (perl-mldbm): New variable.
---
 gnu/packages/perl.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8cf34bf78b..afcc708458 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7193,6 +7193,29 @@  (define-public perl-mixin-linewise
 file names are added for you.")
     (license (package-license perl))))
 
+(define-public perl-mldbm
+  (package
+    (name "perl-mldbm")
+    (version "2.05")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/C/CH/CHORNY/MLDBM-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "18hp5bq5jl6v1prc9sz6xkpys0q27vhlfivkysxim0101knq0s2q"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build))
+    (propagated-inputs (list perl-carp perl-data-dumper perl-storable))
+    (home-page "https://metacpan.org/release/MLDBM")
+    (synopsis "Store a Perl hash structure in single level tied hash")
+    (description
+     "This module can serve as a transparent interface to any TIEHASH package
+that is required to store arbitrary perl data, including nested references.
+Thus, this module can be used for storing references and other arbitrary data
+within DBM databases.")
+    (license (package-license perl))))
+
 (define-public perl-modern-perl
   (package
     (name "perl-modern-perl")