diff mbox series

[bug#55179,WIP,09/30] gnu: perl6-zef: Update to 0.13.8.

Message ID 20220429051700.373076-9-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:17 a.m. UTC
* gnu/packages/perl6.scm (perl6-zef): Update to 0.13.8.
[source]: Reindent.
[arguments]: Replace Perl with Raku in 'check' phase.
[synopsis, description]: Replace mentions of Perl with Raku.
---
 gnu/packages/perl6.scm | 27 +++++++++++++--------------
 1 file changed, 13 insertions(+), 14 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 18acbdbbbd..61be540ed8 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -829,17 +829,16 @@  (define-public perl6-xml-writer
 (define-public perl6-zef
   (package
     (name "perl6-zef")
-    (version "0.6.7")
+    (version "0.13.8")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/ugexe/zef")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "07n7g1xw2c4g860rs890gx85vyhdq0ysgwbrnzw6q905jph2bkv7"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ugexe/zef")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zmx2gavi975811kskv5j4j2zsysnxfklwx0azn8rffraadnhscm"))))
     (build-system rakudo-build-system)
     (arguments
      '(#:with-zef? #f
@@ -848,11 +847,11 @@  (define-public perl6-zef
          (replace 'check
            (lambda _
              (setenv "HOME" "/tmp")
-             (invoke "perl6" "-I." "bin/zef" "--debug"
+             (invoke "raku" "-I." "bin/zef" "--debug"
                      "--tap-harness" "test" "."))))))
     (home-page "https://github.com/ugexe/zef")
-    (synopsis "Perl6 Module Management")
-    (description "Zef is a Perl 6 package (module) manager.  It can be used to
-download and install Perl 6 modules in your home directory or as a system-wide
+    (synopsis "Raku Module Management")
+    (description "Zef is a Raku package (module) manager.  It can be used to
+download and install Raku modules in your home directory or as a system-wide
 module.")
     (license license:artistic2.0)))