diff mbox series

[bug#55179,WIP,13/30] gnu: perl6-json: Perl -> Raku.

Message ID 20220429051700.373076-13-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:18 a.m. UTC
* gnu/packages/perl6.scm (perl6-json): Extract commit outside of source.
[description]: Replace mention of Perl with Raku.
---
 gnu/packages/perl6.scm | 38 +++++++++++++++++++-------------------
 1 file changed, 19 insertions(+), 19 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index aa38f4dbba..c4d1b7b352 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -359,27 +359,27 @@  (define-public perl6-grammar-profiler-simple
       (license license:artistic2.0))))

 (define-public perl6-json
-  (package
-    (name "perl6-json")
-    (version "1.0")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
+  ;; The commit where 1.0 was “tagged”.
+  (let ((commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99"))
+    (package
+      (name "perl6-json")
+      (version "1.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
                (url "https://github.com/moritz/json")
-               ;; The commit where 1.0 was "tagged"
-               (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
-    (build-system rakudo-build-system)
-    (arguments '(#:with-zef? #f))
-    (home-page "https://github.com/moritz/json")
-    (synopsis "Minimal JSON (de)serializer")
-    (description "This module is a simple Perl 6 module for serializing and
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
+      (build-system rakudo-build-system)
+      (arguments '(#:with-zef? #f))
+      (home-page "https://github.com/moritz/json")
+      (synopsis "Minimal JSON (de)serializer")
+      (description "This module is a simple Raku module for serializing and
 deserializing JSON.")
-    (license license:artistic2.0)))
+      (license license:artistic2.0))))

 (define-public perl6-json-class
   (package