diff mbox series

[bug#55179,WIP,02/30] gnu: nqp: Remove trailing booleans.

Message ID 20220429051700.373076-2-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:17 a.m. UTC
* gnu/packages/perl6.scm (nqp)[source]: Reindent.
[snippet]: Remove trailing boolean (and therefore the 'begin').
[arguments]: Remove trailing booleans. Reindent.
---
 gnu/packages/perl6.scm | 32 ++++++++++++++------------------
 1 file changed, 14 insertions(+), 18 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 3c3646587a..5f807a1743 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -100,17 +100,16 @@  (define-public nqp
     (name "nqp")
     (version "2019.03")
     (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "https://rakudo.perl6.org/downloads/nqp/nqp-"
-                            version ".tar.gz"))
-        (sha256
-         (base32
-          "183zhll13fx416s3hkg4bkvib77kyr857h0nydgrl643fpacxp83"))
-        (modules '((guix build utils)))
-        (snippet
-         '(begin
-            (delete-file-recursively "3rdparty") #t))))
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://rakudo.perl6.org/downloads/nqp/nqp-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "183zhll13fx416s3hkg4bkvib77kyr857h0nydgrl643fpacxp83"))
+       (modules '((guix build utils)))
+       (snippet
+        '(delete-file-recursively "3rdparty"))))
     (build-system perl-build-system)
     (arguments
      '(#:phases
@@ -125,21 +124,18 @@  (define-public nqp
                             "tools/build/gen-moar-runner.pl"
                             "t/nqp/111-spawnprocasync.t"
                             "t/nqp/113-run-command.t")
-               (("/bin/sh") (which "sh")))
-             #t))
+               (("/bin/sh") (which "sh")))))
          (add-after 'unpack 'patch-source-date
            (lambda _
              (substitute* "tools/build/gen-version.pl"
-               (("gmtime") "gmtime(0)"))
-             #t))
+               (("gmtime") "gmtime(0)"))))
          (add-after 'unpack 'remove-failing-test
            ;; One subtest fails for unknown reasons
            (lambda _
-             (delete-file "t/nqp/019-file-ops.t")
-             #t))
+             (delete-file "t/nqp/019-file-ops.t")))
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out  (assoc-ref outputs "out"))
+             (let ((out (assoc-ref outputs "out"))
                    (moar (assoc-ref inputs "moarvm")))
                (invoke "perl" "Configure.pl"
                        "--backends=moar"