diff mbox series

[bug#55179,WIP,16/30] gnu: perl6-json-name: Update to 0.0.6.

Message ID 20220429051700.373076-16-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:18 a.m. UTC
* gnu/packages/perl6.scm (perl6-json-name): Update to 0.0.6.
[source]: Reindent.
[propagated-inputs]: Add perl6-json-optin.
[synopsis, description]: Fix minor stylistic issues.
---
 gnu/packages/perl6.scm | 25 +++++++++++++------------
 1 file changed, 13 insertions(+), 12 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 54e3aa0b11..0eff0e831f 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -464,27 +464,28 @@  (define-public perl6-json-marshal
 (define-public perl6-json-name
   (package
     (name "perl6-json-name")
-    (version "0.0.3")
+    (version "0.0.6")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/jonathanstowe/JSON-Name")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "130qwdpbj5qdlsdz05y0rksd79lzbq79scy47n6lnf21b0hz1qjc"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jonathanstowe/JSON-Name")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fbwp3av4kh7zlbrmgbka4x6s3d6fsw2qxafi9hyq0y896wsaf94"))))
     (build-system rakudo-build-system)
     (arguments '(#:with-zef? #f))
+    (propagated-inputs
+     (list perl6-json-optin))
     (home-page "https://github.com/jonathanstowe/JSON-Name")
-    (synopsis "Provides a trait to store an alternative JSON Name")
+    (synopsis "Provide a trait to store an alternative JSON name")
     (description "This is released as a dependency of @code{JSON::Marshal} and
 @code{JSON::Unmarshal} in order to save duplication, it is intended to store a
 separate JSON name for an attribute where the name of the JSON attribute might be
 changed, either for aesthetic reasons or the name is not a valid Perl identifier.
 It will of course also be needed in classes thar are going to use
-@code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
+@code{JSON::Marshal} or @code{JSON::Unmarshal} for serialization/deserialization.")
     (license license:artistic2.0)))

 (define-public perl6-json-optin