diff mbox series

[bug#55179,WIP,08/30] gnu: perl6-tap-harness: Update to 0.3.5.

Message ID 20220429051700.373076-8-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:17 a.m. UTC
* gnu/packages/perl6.scm (perl6-tap-harness): Update to 0.3.5.
[source]: Update URL. Reindent.
[arguments]: Replace obsolete prove6 script with manual Raku invocation
in 'check' phase.
[home-page]: Update.
[synopsis]: Replace mention of Perl with Raku.

* gnu/packages/rakudo-build-system.scm (check): Replace obsolete prove6
script with manual Raku invocation.
---
 gnu/packages/perl6.scm             | 25 ++++++++++++-------------
 guix/build/rakudo-build-system.scm |  6 +++++-
 2 files changed, 17 insertions(+), 14 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 3dfdeec4f1..18acbdbbbd 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -680,17 +680,16 @@  (define-public perl6-svg-plot
 (define-public perl6-tap-harness
   (package
     (name "perl6-tap-harness")
-    (version "0.0.7")
+    (version "0.3.5")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/perl6/tap-harness6")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1lig8i0my3fgqvlay9532xslbf3iis2d7wz89gniwvwqffi2kh6r"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Raku/tap-harness6")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "162crdy8g6xhnry26pjma2panm0c79n26igmljg79al4bqj9lyc9"))))
     (build-system rakudo-build-system)
     (arguments
      '(#:with-zef? #f
@@ -699,9 +698,9 @@  (define-public perl6-tap-harness
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             (invoke "perl6" "-Ilib" "bin/prove6" "-l" "t"))))))
-    (home-page "https://github.com/perl6/tap-harness6/")
-    (synopsis "TAP harness for perl6")
+             (invoke "raku" "-MTAP" "-Ilib" "-l" "t"))))))
+    (home-page "https://github.com/Raku/tap-harness6")
+    (synopsis "TAP harness for Raku")
     (description "This module provides the @command{prove6} command which runs a
 TAP based test suite and prints a report.  The @command{prove6} command is a
 minimal wrapper around an instance of this module.")
diff --git a/guix/build/rakudo-build-system.scm b/guix/build/rakudo-build-system.scm
index 642cc570d1..8f9a3b11d8 100644
--- a/guix/build/rakudo-build-system.scm
+++ b/guix/build/rakudo-build-system.scm
@@ -36,7 +36,11 @@  (define-module (guix build rakudo-build-system)
 (define* (check #:key tests? inputs with-prove6? #:allow-other-keys)
   (if (and tests? (assoc-ref inputs "perl6-tap-harness"))
   ;(if (and tests? with-prove6?)
-      (invoke "prove6" "-I=lib" "t/")
+      (let ((test-files (find-files "t/" "\\.(rakutest|t|t6)$")))
+        (invoke "raku" "-MTAP" "-e"
+                (string-append
+                 "my @tests = <" (string-join test-files " ") ">; "
+                 "TAP::Harness.new().run(@tests);")))
       (format #t "test suite not run~%"))
   #t)