diff mbox series

[bug#55179,WIP,15/30] gnu: Add perl6-json-optin.

Message ID 20220429051700.373076-15-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:18 a.m. UTC
* gnu/packages/perl6.scm (perl6-json-optin): New variable.
---
 gnu/packages/perl6.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index e00a6c5d23..54e3aa0b11 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -487,6 +487,29 @@  (define-public perl6-json-name
 @code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
     (license license:artistic2.0)))

+(define-public perl6-json-optin
+  (package
+    (name "perl6-json-optin")
+    (version "0.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jonathanstowe/JSON-OptIn")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0iz1wd3rfcb3kdc8cylwfxr8p02bpivk7kcf3dmm2l4mmdhyk7np"))))
+    (build-system rakudo-build-system)
+    (arguments '(#:with-zef? #f))
+    (home-page "https://github.com/jonathanstowe/JSON-OptIn")
+    (synopsis "Provide a trait and role to identify opt-in JSON serialization")
+    (description "This provides a trait and a role for the identification of
+`opt in' serializable attributes in, e.g., @code{JSON::Marshal}.  It's
+probably not necessary to use this directly as it will be required by, e.g.,
+@code{JSON::Name}, but it's just more convenient to package it separately.")
+    (license license:artistic2.0)))
+
 (define-public perl6-json-unmarshal
   ;; Last commit was May 2017
   (let ((commit "e1b6288c5f3165058f36c0f4e171cdf2dfd640da")