diff mbox series

[bug#55179,WIP,12/30] gnu: perl6-grammar-profiler-simple: Perl -> Raku.

Message ID 20220429051700.373076-12-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:18 a.m. UTC
* gnu/packages/perl6.scm (perl6-grammar-profiler-simple)[source]:
Reindent.
[synopsis, description]: Replace mentions of Perl with Raku.
---
 gnu/packages/perl6.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index a9b5ba0ae8..aa38f4dbba 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -333,27 +333,26 @@  (define-public perl6-grammar-debugger
       (license license:artistic2.0))))

 (define-public perl6-grammar-profiler-simple
-  ;; Last commit was June 2017
+  ;; Last commit was June 2017.
   (let ((commit "c0aca5fab323b2974821dabd6b89330c609e0b7d")
         (revision "1"))
     (package
       (name "perl6-grammar-profiler-simple")
       (version (git-version "0.02" revision commit))
       (source
-        (origin
-          (method git-fetch)
-          (uri (git-reference
-                 (url "https://github.com/perlpilot/Grammar-Profiler-Simple")
-                 (commit commit)))
-          (file-name (git-file-name name version))
-          (sha256
-           (base32
-            "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/perlpilot/Grammar-Profiler-Simple")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
       (build-system rakudo-build-system)
       (arguments '(#:with-zef? #f))
       (home-page "https://github.com/perlpilot/Grammar-Profiler-Simple")
-      (synopsis "Simple rule profiling for Perl 6 grammars")
-      (description "This module provides a simple profiler for Perl 6 grammars.
+      (synopsis "Simple rule profiling for Raku grammars")
+      (description "This module provides a simple profiler for Raku grammars.
 To enable profiling simply add use @code{Grammar::Profiler::Simple;} to your
 code.  Any grammar in the lexical scope of the use statement will automatically
 have profiling information collected when the grammar is used.")