diff mbox series

[bug#55179,WIP,17/30] gnu: perl6-json-marshal: Update to 0.0.23.

Message ID 20220429051700.373076-17-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:18 a.m. UTC
* gnu/packages/perl6.scm (perl6-json-marshal): Update to 0.0.23.
[source]: Reindent.
[propagated-inputs]: Move below native-inputs.
[synopsis]: Serialisation -> serialization.
---
 gnu/packages/perl6.scm | 25 ++++++++++++-------------
 1 file changed, 12 insertions(+), 13 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 0eff0e831f..ed47ec58b9 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -438,24 +438,23 @@  (define-public perl6-json-fast
 (define-public perl6-json-marshal
   (package
     (name "perl6-json-marshal")
-    (version "0.0.16")
+    (version "0.0.23")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/jonathanstowe/JSON-Marshal")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "0qy7j83h6gjzyyv74ncd92cd9h45rv8diaz3vldiv3b6fqwz4c6i"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jonathanstowe/JSON-Marshal")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "057xmdadhy5wkbhr6w1iybv2j7qf4bf8d4cp8m4qdcgk6pqzpkgc"))))
     (build-system rakudo-build-system)
-    (propagated-inputs
-     (list perl6-json-fast perl6-json-name))
     (native-inputs
      (list perl6-json-fast))
+    (propagated-inputs
+     (list perl6-json-fast perl6-json-name))
     (home-page "https://github.com/jonathanstowe/JSON-Marshal")
-    (synopsis "Simple serialisation of objects to JSON")
+    (synopsis "Simple serialization of objects to JSON")
     (description "This library provides a single exported subroutine to create
 a JSON representation of an object.  It should round trip back into an object
 of the same class using @code{JSON::Unmarshal}.")