diff mbox series

[bug#55179,WIP,19/30] gnu: perl6-json-class: Update to 0.0.18.

Message ID 20220429051700.373076-19-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:18 a.m. UTC
* gnu/packages/perl6.scm (perl6-json-class): Update to 0.0.18.
[source]: Reindent.
[propagated-inputs]: Move below native-inputs.
[synopsis, description]: Fix minor stylistic issues.
---
 gnu/packages/perl6.scm | 29 ++++++++++++++---------------
 1 file changed, 14 insertions(+), 15 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 5af4dbdfb6..e22492ec2f 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -384,30 +384,29 @@  (define-public perl6-json
 (define-public perl6-json-class
   (package
     (name "perl6-json-class")
-    (version "0.0.12")
+    (version "0.0.18")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/jonathanstowe/JSON-Class")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "1zyzajc57j3m8q0nr72h9pw4w2nx92rafywlvysgphc5q9sb8np2"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jonathanstowe/JSON-Class")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0686qpcb6p5isjcsksrgsr1rh926cnhs6r091p5p3lh2fd575g1d"))))
     (build-system rakudo-build-system)
-    (propagated-inputs
-     (list perl6-json-marshal perl6-json-unmarshal))
     (native-inputs
      (list perl6-json-fast))
+    (propagated-inputs
+     (list perl6-json-marshal perl6-json-unmarshal))
     (home-page "https://github.com/jonathanstowe/JSON-Class")
-    (synopsis "Provide simple serialisation/deserialisation of objects to/from JSON")
+    (synopsis "Provide simple serialization/deserialization of objects to/from JSON")
     (description "This is a simple role that provides methods to instantiate a
-class from a JSON string that (hopefully,) represents it, and to serialise an
+class from a JSON string that (hopefully) represents it, and to serialize an
 object of the class to a JSON string.  The JSON created from an instance
 should round trip to a new instance with the same values for the public
 attributes.  Private attributes (that is ones without accessors,) will be
-ignored for both serialisation and de-serialisation.  The exact behaviour
+ignored for both serialization and deserialization.  The exact behaviour
 depends on that of @code{JSON::Marshal} and @code{JSON::Unmarshal}
 respectively.")
     (license license:artistic2.0)))