diff mbox series

[bug#55179,WIP,22/30] gnu: perl6-mime-base64: Update to 1.2.3.

Message ID 20220429051700.373076-22-paul@apatience.com
State New
Headers show
Series gnu: rakudo: Update to 2022.04 and packages too. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience April 29, 2022, 5:19 a.m. UTC
* gnu/packages/perl6.scm (perl6-mime-base64): Update to 1.2.3.
[source]: Update URL. Reindent.
[home-page]: Update.
[description]: Replace mention of Perl with Raku.
---
 gnu/packages/perl6.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)

--
2.36.0
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 6f9be54cf4..f4ed67d431 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -594,22 +594,21 @@  (define-public perl6-meta6
 (define-public perl6-mime-base64
   (package
     (name "perl6-mime-base64")
-    (version "1.2.1")
+    (version "1.2.3")
     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/perl6/Perl6-MIME-Base64")
-               (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32
-          "0l67m8mvz3gxml425sd1ggfnhzh4lf754k7w8fngfr453s6lsza1"))))
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/raku-community-modules/MIME-Base64")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "19bndwbjr05gg8rrq2msmw1ik8xw2r3gbd77vxrp8l6c674zgy95"))))
     (build-system rakudo-build-system)
     (arguments '(#:with-zef? #f))
-    (home-page "https://github.com/perl6/Perl6-MIME-Base64")
+    (home-page "https://github.com/raku-community-modules/MIME-Base64")
     (synopsis "Encoding and decoding Base64 ASCII strings")
-    (description "This Perl 6 module implements encoding and decoding to and
+    (description "This Raku module implements encoding and decoding to and
 from base64.")
     (license license:artistic2.0)))