diff mbox series

[bug#50835,v2,23/24] gnu: Add ghc-multibase.

Message ID 20220114024546.75747-23-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-multibase): New variable.
---
 gnu/packages/haskell-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a137b8b5da..c27064a327 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16600,3 +16600,33 @@  https://gist.github.com/maaku/8996338#file-bip-ecc32-mediawiki.")
     (description
       "Tasty-fail-fast wraps any ingredient to fail as soon as the first test fails.")
     (license license:bsd-3)))
+
+(define-public ghc-multibase
+  (package
+    (name "ghc-multibase")
+    (version "0.1.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "multibase" version))
+        (sha256
+          (base32 "036caj0dzhzp065dhy05flz2j5qml5pirs1y95np4hf2xv9jk32h"))))
+    (build-system haskell-build-system)
+    (inputs
+      (list ghc-aeson
+            ghc-base16-bytestring
+            ghc-base32-z-bytestring
+            ghc-base58-bytestring
+            ghc-base64-bytestring
+            ghc-formatting
+            ghc-hashable
+            ghc-sandi
+            ghc-serialise
+            ghc-tagged))
+    (native-inputs (list ghc-doctest ghc-quickcheck ghc-cabal-doctest))
+    (home-page "https://github.com/monadic-xyz/ipfs")
+    (synopsis "Multibase for Haskell")
+    (description
+      "Multibase implements self-identifying base encodings as an implementation
+of https://github.com/multiformats/multihash.")
+    (license license:bsd-3)))