diff mbox series

[bug#50835,v2,20/24] gnu: Add ghc-formatting.

Message ID 20220114024546.75747-20-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-formatting): New variable.
---
 gnu/packages/haskell-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 93b81f19de..7ad9c3eabd 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16537,3 +16537,24 @@  like endianness and architecture.")
 codecs according to RFC4648, extended to support z-base32 encoding according to
 https://gist.github.com/maaku/8996338#file-bip-ecc32-mediawiki.")
     (license license:bsd-3)))
+
+(define-public ghc-formatting
+  (package
+    (name "ghc-formatting")
+    (version "7.1.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "formatting" version))
+        (sha256
+          (base32 "1vrc2i1b6lxx2aq5hysfl3gl6miq2wbhxc384axvgrkqjbibnqc0"))))
+    (build-system haskell-build-system)
+    (inputs
+      (list ghc-clock ghc-old-locale ghc-scientific ghc-double-conversion))
+    (native-inputs (list ghc-hspec))
+    (home-page "https://github.com/AJChapman/formatting")
+    (synopsis
+      "Combinator-based type-safe formatting (like printf() or FORMAT)")
+    (description
+      "Formatting implements combinator-based type-safe formatting.")
+    (license license:bsd-3)))