diff mbox series

[bug#50835,v2,22/24] gnu: Add ghc-tasty-fail-fast.

Message ID 20220114024546.75747-22-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-tasty-fail-fast): New variable.
---
 gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7e654c6edf..a137b8b5da 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16577,3 +16577,26 @@  https://gist.github.com/maaku/8996338#file-bip-ecc32-mediawiki.")
     (description
       "Tasty TAP is a tasty ingredient to output test results in TAP 13 format.")
     (license license:expat)))
+
+(define-public ghc-tasty-fail-fast
+  (package
+    (name "ghc-tasty-fail-fast")
+    (version "0.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MichaelXavier/tasty-fail-fast")
+             (commit "68d7f182f4d1f7b97a724c26f554e5da27fe9413")))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32 "05x4ly5sfj5fmjsxxrfys20qc6n078vwaxxzlk2l354l7kng5512"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-tasty ghc-tagged))
+    (native-inputs (list ghc-tasty-hunit ghc-tasty-golden ghc-tasty-tap))
+    (home-page "https://github.com/MichaelXavier/tasty-fail-fast")
+    (synopsis
+      "Adds the ability to fail a tasty test suite on first test failure")
+    (description
+      "Tasty-fail-fast wraps any ingredient to fail as soon as the first test fails.")
+    (license license:bsd-3)))