diff mbox series

[bug#50835,v2,10/24] gnu: Add ghc-unexceptionalio-trans.

Message ID 20220114024546.75747-10-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-unexceptional-trans): New variable.
---
 gnu/packages/haskell-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index cf96ca2633..ebee13023e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -13615,6 +13615,33 @@  unbounded @code{Integer} type.")
 handled safely, this is what you're left with.")
     (license license:isc)))
 
+(define-public ghc-unexceptionalio-trans
+  (package
+    (name "ghc-unexceptionalio-trans")
+    (version "0.5.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "unexceptionalio-trans" version))
+        (sha256
+          (base32 "100sfbrpaldz37a176qpfkk1nx5acyh8pchjmb8g5vhzbhyrqniz"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-unexceptionalio))
+    (arguments
+      `(#:cabal-revision
+        ("1" "0f15n8hqqczwjrcqxwjp2mrd9iycv53sylv407c95nb6d4hw93ci")))
+    (home-page "https://github.com/singpolyma/unexceptionalio-trans")
+    (synopsis "Wrapper around UnexceptionalIO using monad transformers")
+    (description
+      "UnexceptionalIO provides a basic type to witness having caught all
+exceptions you can safely handle.  This library builds on that with
+transformers like ExceptT to provide a more ergonomic tool for many cases.
+It is intended that you use qualified imports with this library.
+
+> import UnexceptionalIO.Trans (UIO)
+> import qualified UnexceptionalIO.Trans as UIO")
+    (license license:isc)))
+
 (define-public ghc-unicode-transforms
   (package
     (name "ghc-unicode-transforms")