diff mbox series

[bug#50835,v2,08/24] gnu: Add ghc-network-simple.

Message ID 20220114024546.75747-8-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-network-simple): New variable.
---
 gnu/packages/haskell-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a206e8cabb..8c02385f26 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16265,3 +16265,22 @@  SAX parser.")
     (description
       "This library provides low-level bindings for using libidn in Haskell.")
     (license license:gpl3)))
+
+(define-public ghc-network-simple
+  (package
+    (name "ghc-network-simple")
+    (version "0.4.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hackage-uri "network-simple" version))
+        (sha256
+          (base32 "17hpgcwrsx2h8lrb2wwzy0anp33mn80dnwcgnqmb8prajwjvz807"))))
+    (build-system haskell-build-system)
+    (inputs (list ghc-network ghc-network-bsd ghc-safe-exceptions ghc-socks))
+    (home-page "https://github.com/k0001/network-simple")
+    (synopsis "Simple network sockets usage patterns")
+    (description
+      "Network Simple exports functions that abstract simple network socket
+usage patterns.")
+    (license license:bsd-3)))