diff mbox series

[bug#50835,v2,09/24] gnu: Add ghc-network-protocol-xmpp.

Message ID 20220114024546.75747-9-singpolyma@singpolyma.net
State New
Headers show
Series [bug#50835,v2,01/24] gnu: Add ghc-cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/issue success View issue

Commit Message

Stephen Paul Weber Jan. 14, 2022, 2:45 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-network-protocol-xmpp): New variable.
---
 gnu/packages/haskell-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 8c02385f26..cf96ca2633 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16284,3 +16284,34 @@  SAX parser.")
       "Network Simple exports functions that abstract simple network socket
 usage patterns.")
     (license license:bsd-3)))
+
+(define-public ghc-network-protocol-xmpp
+  (package
+    (name "ghc-network-protocol-xmpp")
+    (version "0.4.10")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/"
+               "network-protocol-xmpp/network-protocol-xmpp-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32 "03xlw8337lzwp7f5jvbvgirf546pfmfsfjvnik08qjjy1rfn5jji"))))
+    (build-system haskell-build-system)
+    (inputs
+      (list
+        ghc-gnuidn
+        ghc-gnutls
+        ghc-gsasl
+        ghc-libxml-sax
+        ghc-monads-tf
+        ghc-network
+        ghc-network-simple
+        ghc-xml-types))
+    (home-page "https://git.singpolyma.net/network-protocol-xmpp")
+    (synopsis "Client library for the XMPP protocol")
+    (description "Network-protocol-XMPP is a client or component library for XMPP.
+Does only what it needs to do and nothing more, no XEP wrappers etc.")
+    (license license:gpl3)))